PUZZLE EFFECTS – 2D
Photoshop Actions
For Adobe® Photoshop® CC, CS6, CS5, CS4

User Guide
CONTENTS

1. THE BASICS ..............................................................................................................................................1
   1.1. About the actions ............................................................................................................................1
   1.2. How the actions are organized.......................................................................................................1
   1.3. The “Classic” effects (examples) ..................................................................................................3
   1.4. The “Special” effects (examples) ..................................................................................................5

2. INSTALLATION & TROUBLESHOOTING ............................................................................................8
   2.1. Installing the actions .......................................................................................................................8
   2.2. Removing an older version (or a trial one) ...................................................................................8
   2.3. Requirements ..................................................................................................................................8
   2.4. Troubleshooting .............................................................................................................................8

3. USING THE “CLASSIC” PUZZLES ACTIONS ....................................................................................9
   3.1. Creating the Puzzle .......................................................................................................................9
   3.2. The various layers .......................................................................................................................10
   3.3. Moving individual pieces .............................................................................................................11

4. USING THE “SPECIAL” PUZZLES ACTIONS ..................................................................................12
   4.1. Creating the Puzzle .......................................................................................................................12
   4.2. The various layers .......................................................................................................................14
1. THE BASICS

1.1. About the actions
The Puzzle Effects actions turn your photos into digital jigsaw puzzles. In the 2D actions each piece is an individual layer; this lets you create impressive static or animated puzzles in Adobe Photoshop or even using other programs.

The actions create a remarkable range of different jigsaw puzzles. This guide describes the way the 2D Puzzle actions work.

1.2. How the actions are organized
The 2D Puzzle Effects include two sets of actions:

- The “Classic” effects.
- The “Special” effects.
The “Classic” Puzzle effects, as the name indicates, replicate the look of a classic paperboard jigsaw puzzle.

You can turn your photos into digital puzzles with up to 210 pieces.

What’s exceptionally useful is that each piece is an individual layer. This allows you to move & rotate individual pieces or even whole groups of pieces!

The “Special” Puzzle effects include an impressive assortment of creative puzzle effects, such as spiral puzzles (like the example on the right), hearts, or diamonds, to name a few.
1.3. The “Classic” effects (examples)

The examples below demonstrate the 14 puzzles produced by the ‘Classic’ actions:
64 pieces - 'open edges' style

72 pieces

100 pieces

156 pieces - 'open edges' style

210 pieces

© Panos Efstathiadis | all rights reserved
1.4. The “Special” effects (examples)

The examples below demonstrate the 23 effects produced by the ‘Special’ actions:
2. INSTALLATION & TROUBLESHOOTING

2.1. Installing the actions
If you don’t know how to install and use Photoshop actions, please refer to this article on PanosFX.com:
http://www.panosfx.com/installation-troubleshooting/installing-photoshop-actions

2.2. Removing an older version (or a trial one)
If you have an older product version installed, or if you installed the trial version before purchasing the full one, I recommend you remove it prior to installing the new files. This article shows you how to do it:
http://www.panosfx.com/installation-troubleshooting/uninstalling

2.3. Requirements
The 2D Puzzles actions can be used with Adobe® Photoshop® CS4 or newer (32 & 64bit). Your system should meet the minimum requirements, as provided by Adobe:
https://helpx.adobe.com/photoshop/system-requirements.html

2.4. Troubleshooting
Make sure you read the following pages, in order to understand how the actions work. If you notice that Photoshop behaves abnormally proceed with resetting the preferences the way described in this article:
https://www.panosfx.com/installation-troubleshooting/reset-preferences
3. USING THE “CLASSIC” PUZZLES ACTIONS

3.1. Creating the Puzzle

The actions in the “Classic” set create 14 different jigsaw puzzles, with up to 210 individual pieces. All actions work in the same way.

The creation of the puzzles involves 2 steps:

- **STEP 1:** Load a photo and run one of the actions in the “STEP 1. CREATE THE PUZZLE:” group
- **STEP 2:** Run one of the 6 actions in the “STEP 2. ADJUST THE PIECES' BEVELS:” group, to adjust the bevels of the puzzle pieces.

**STEP 1:**

Begin with loading one photo of *landscape orientation*. If your photo has a *portrait* orientation, rotate it by 90 degrees prior to running the actions using the menu command: **Image > Image Rotation > 90° Clockwise**. When the action finishes, restore the original orientation using the command: **Image > Image Rotation > 90° Counter Clockwise**.

Select one of the 14 Classic actions and hit the **Play** button. The action will cut the puzzle pieces and create a *different layer* for every piece. This may take a while, depending on the number of pieces and your system.

**STEP 2:**

When the action finishes, run the “**Re-scale Styles**” action to optimize the layer styles (bevels) of the pieces.

The “Scale Layer Effects” dialogue box shows up, with the Scale set to 100% by default. Change it using these values as a reference:

- Set Scale to 250% or more, if the original image is very big (>15 Megapixels).
- Set Scale between 160 to 250 %, if the image size is between 8 to 5 Megapixels.
- Set Scale between 120 to 160%, if the image size is between 3 to 8 Megapixels.
- Set Scale between 40- to 80 %, if the image is very small (<1 Megapixel).
3.2. The various layers

When the action finishes, each piece is contained in its own layer.

**TIP:** To collapse the styles information shown below each layer, hold down the Alt key (Mac: option) and click the up-arrow to the right of the styles (fx) icon:

In the “Classic” puzzle actions, all pieces are arranged in rows and columns.

The layer name format is: “Row X – X”, indicating the position of the respective piece.

*Example: When you select the “Row 4 – 9” layer, you select the 9th piece in the 4th row.*

The ‘background’ is the last layer in the layers panel. To increase the canvas size use the menu command: **Image > Canvas Size.**
3.3. Moving individual pieces

When the action finishes you can create an image that looks like an incomplete jigsaw puzzle, by moving one or more individual pieces, or even groups of pieces. This technique will make your puzzle images look even more interesting.

Before attempting to move any pieces, I recommend you go to the **History panel** (select: **Window > History**) and click on the little camera icon to create a snapshot of the current document state. This provides an easy way to undo any changes.

To select a piece, right click on it and select the **second** option from the pop-up menu:

Alternatively, you can hold down the **Ctrl** key (Mac: **cmd**) and click on the piece.

To select *multiple* pieces, hold down **Shift**, right click on *each* piece and select the second option from the pop-up menu. Another way is to hold down the **Ctrl** key (Mac: **cmd**) and click on the first piece you wish to select. Then hold down **Shift-Ctrl** (Mac: **Shift-cmd**) and click on the next piece(s) you wish to select.

Having selected a piece (or multiple pieces), press **Ctrl-T** (Mac: **cmd-T**). Use your mouse to move and/or rotate the pieces:

You may want to drag the selected layers at the top of the **Layers Panel** if they overlap with the other pieces.
4. USING THE “SPECIAL” PUZZLES ACTIONS

4.1. Creating the Puzzle

The actions in the “Special” set create 24 different jigsaw puzzles. The creation of the puzzles involves 2 steps:

- **STEP 1**: Load a photo and run one of the actions in the “STEP 1. CREATE THE PUZZLE:” group
- **STEP 2**: Run one of the 6 actions in the “STEP 2. ADJUST THE PIECES’ BEVELS:” group, to adjust the bevels of the puzzle pieces.

**STEP 1:**

To begin, load one photo of any ratio in Photoshop.

Select one action in the first group, and hit the Play button. The action begins with placing a vector shape over your photo:

- It lets you define which pixels will be included in the puzzle.
- It lets you preview the exact edges of each piece.

Drag any of the 4 corner handles to resize the shape. Do not drag any of the middle handles! You can also rotate or move the vector overlay using your mouse.

When you finish, double click inside the vector shape to move on. The action will crop the photo and cut the individual puzzle pieces. While cutting the puzzle pieces, the action creates a unique layer for every puzzle piece.
STEP 2:

When the action finishes, run the “Re-scale Styles” action to optimize the layer styles (bevels) of the pieces.

The “Scale Layer Effects” dialogue box shows up, with the Scale set to 100% by default. Change it using these values as a reference:

- Set Scale to 250% or more, if the original image is very big (>15 Megapixels).
- Set Scale between 160 to 250 %, if the image size is between 8 to 5 Megapixels.
- Set Scale between 120 to 160%, if the image size is between 3 to 8 Megapixels.
- Set Scale between 40- to 80 %, if the image is very small (<1 Megapixel).
4.2. The various layers

The “Shadow” layer is located above the background layer, at the end of the layers’ stack, in the layers panel. You can change its opacity to preference. You can also press Ctrl-T (Mac: cmd-T) and reposition it, or resize it to your preference.

The “background” is the last layer in the layers panel. You can double click the fx button to modify (or turn off) the default gradient overlay style. You may also add a gradient fill / pattern fill / Color fill adjustment layer. You may delete this layer and insert a background image of your preference, using the File > Place Embedded command (in Photoshop CC) or the File > Place command (in older Photoshop versions).

Finally, you can modify the canvas size using either the Image > Canvas Size menu command, or the Crop tool. If you increase the canvas size, do not forget to fill the background layer with white color (press Shift-F5).

**TIP:** To collapse the styles information shown below each layer, hold down the Alt key (Mac: option) and click the up-arrow to the right of the styles (fx) icon.

Unlike the “Classic puzzles” actions, in the “Special” puzzles the pieces are not always arranged in rows and columns. This is the case e.g. in the “Spiral” puzzles or the “Hearts”. The layers naming approach is therefore different: the layer name indicates the position of the piece in the puzzle (e.g. “Top”, “Left”, etc.)

In the “Spiral” puzzles, the numbering of the layers begins from the outer piece.
If you have any questions, please use the contact form on PanosFX.com, or use the site forum.

Panos Efstathiadis

www.PanosFX.com

The photos used in this guide were kindly provided by Shutterstock. The Shutterstock IDs are as follows:

364080782.jpg

100157897.jpg